SYRIUS v0.0.6 Crashes With Embedded Node

There’s is an issue with SYRIUS 0.0.6 and Windows 10 for some people. Looks like an embedded node issue, it crashes SYRIUS upon start.

Only way to run SYRIUS 0.0.6 in this case is to connect to another node (not embedded) on v0.0.5 then close SYRIUS and reopen 0.0.6. But as soon as you try to connect to the embedded node on 0.0.6 it crashes again

Happens only for a few, exclusively on Win 10…weird

While the bug is being investigated users can feel free to use my trusted node wss://

1 Like

Users have also reported another work around. They are downloading and running znnd on the machine that is running SYRIUS.

They download the appropriate file here Run it locally, and then start SYRIUS with the embedded node. SYRIUS will then start without crashing. Seems like many users are having this issue.

1 Like

I will try to replicate the problem on my W10 machine.

1 Like

Syrius crashes in win 10 if znnd is not running concurrently. Once znnd is synced. It works fine


I’m trying to replicate the problem, but on my Windows 10 machine s y r i u s v0.0.6 is working whether znnd is synced or not.

Steps involved

  1. Removed users znn directory
  2. Created new wallet under v0.0.5
  3. Synced up to momentum 3336585
  4. Closed v0.0.5
  5. Opened v0.0.6 and resumed syncing process

I ran 0.0.6 after 0.0.5 was fully synced. It crashed. Needs znnd running parallel to it.

Just synced up under v0.0.5, closed it and started v0.0.6 without any issues.

If I understand correctly, your client always crashes if you do not have znnd running parallel to it?

At what stage does the client crash. After or before login. If after, before connecting with peers or after?

@NeoShredder, how did you upgrade to syrius v0.0.6?

  1. Did you run syrius.exe from the archive?
  2. Did you extract the archive and run syrius.exe from the extracted directory?
  3. Did you extract the archive, copy syrius.exe to the old location of v0.0.5 and then run it from there?
  4. Did you extract the archive, copy all the files extracted to the old location of 0.0.5 and then run from there?

I think it’s a great idea @sumamu to paste only the new syrius.exe v0.0.6 (only the executable, without the dlls) and keep all the .dll files from syrius v0.0.5.

Can someone test this scenario?

I can test in 1 hr

@SugoiBTC are you having this issue? Can you trouble shoot the steps above? I cannot replicate the issue. So repeating this steps won’t tell us anything b/ I don’t have the issue to solve unfortunately… :frowning:

Tried that when I encountered this issue but then it gave me some error messages and didn’t even launch.

1 Like

how old is the windows machine and does it have all the updates applied?

What happens if you run the new SYRIUS as administrator (right click, run as administrator). Let’s try this against a new unzip (not the process recommended by @sumamu above).

Posted in the other thread, but for info here I’ve gone through the procmon dumps from 2 faulting PCs and there’s no obvious fault or error. I’ll keep digging later on.

Still can’t replicate it myself either

1 Like

can you look at windows defender and see if it’s quarantined any files?

I have an antivirus, and I made sure to put all the folder in the exception list along with the other syrius versions.

1 Like

everything is updated, and as I mentioned before all the previous syrius versions worked and still working without any issue, I also tried run as admin.

1 Like

this is the error I had when I replaced syrius 0.0.5 with 0.0.6 (only the exe file)

can you find that .dll file in the v0.0.6 directory and copy it over to the v0.0.5 folder?

I’m getting this after moving the missing dll files