Syrius - Bug fixes - Re-delegate ZNN from decommissioned Pillar

Recently 5 of the top NoM Pillars were decommissioned which made evident a bug in the UI of Syrius. If you had your ZNN delegated to one of these Pillars whilst it was decommissioned you would have no option to Undelegate. Syrius would show you the following message on the Dashboard

image

The issue exists because rather than give you a generic undelegate option that would remove your delegation from whatever Pillar was selected, it presents the button inline with the Pillar entry. If the Pillar is removed, so is the button to undelegate.

The temporary fix is quite simple

  • Go to the settings tab and under Addresses select to add new address
    image
  • Copy the new wallet address
    image
  • With your original address selected, go to the transfer tab and send all of the ZNN you wish to delegate to the newly created address
    image
  • Back in the settings tab, select the new wallet address as the active address
    image
  • Wait for the transfer to come through
  • Fuse some QSR to add plasma to the new address if need be
  • Go back to the Pillar tab and select your new delegation preference

We expect the bug to be resolved in a future Syrius release in case you want to retain the original address.

3 Likes

Thanks for making this Romeo. I’m sure this’ll help a lotta people who delegating to those top 5.

I do wonder why he consolidated them all into one pillar. :thinking: Seems like a loss of QSR to me. Anyhoo we thank him for his donation. :clap:

2 Likes

Note, if you compile the dart SDK on the same machine you have the wallet installed, you can use the pillar.undelegate command using the wallet’s password via command line.

This doesn’t require another account, but takes a bit of work. Note there’s a posted issue and pull request that may help:

Syntax once successfully compiled is:

cli_handler.exe -p <password> pillar.undelegate

If you have multiple accounts, account #2 would be and index incremented accordingly (0 is first account):

cli_handler.exe -p <password> pillar.undelegate -i 1

To delegate via command line, it’d be:

cli_handler.exe -p <password> pillar.delegate <name of pillar>

Unsure the status of the other SDKs in development and if any of them are far enough along to accomplish the same thing.

1 Like

is this for Linux only?

I did it on a Mac. I haven’t tried on Windows.

ah I see - I’m fairly certain it won’t work on Windows

I’ve installed the Dart-SDK via choco and attempted to compile but every time it fails with multiple errors

I worked through the errors before there was an issue or pull request put in place. Unsure how much work it’d be to get dart to compile it on Windows, but it wasn’t easy to compile as is on Mac either. The pull request seems promising to making it easier, but I haven’t tested it.

1 Like

@sol_sanctum was it you that were having issues on Windows too? Did you end up having any luck?

I have problems with compiling Syrius on Windows.

I’ve had success with go-zenon, znn-cli, and znn-sdk on Windows.

For cli_handler.exe, I just compiled it on my machine with the following instructions:

  1. git clone GitHub - zenon-network/znn_cli_dart
  2. cd znn_cli_dart
  3. dart pub get
  4. dart compile exe .\cli_handler.dart

If anyone has issues with those instructions, here’s my setup for reference:

dart --version
Dart SDK version: 2.16.2 (stable) (Tue Mar 22 13:15:13 2022 +0100) on “windows_x64”

2 Likes

Oh nice, I’ll try it later on thanks!

I was compiling from my own downloaded copy of the files, perhaps that was causing the errors