Syrius Address Field Grey

I’m doing some syrius testing and just setup a new wallet on a windows 10 VM. I’m getting this strange grey box for address field #1. Has anyone else encountered this issue? If so, how did you resolve it?

That’s a runtime error afaik.

1 Like

I don’t see any errors in the logs. This only happens when I clone a VM and setup Syrius in the cloned VM.

If I can reproduce the issue, I may be able to patch this. I’d need an error to start troubleshooting, though.

You could try a Debug build to see if it’s more verbose in this scenario.

OK. I’ll work on a debug install this weekend and report back. I have 2 different VMs that are doing this. so I hope I can get an error message from debug.

1 Like

I’ll be around. Ping me if you need help :slight_smile:

1 Like

I’ve confirmed that going to Settings > Delete Cache solves the problem.

Documented steps to reproduce this error:

  1. Setup Fresh Windows 10 VM
  2. Install Syrius and setup new wallet
  3. Select external node I run
  4. Clone VM to another instance
  5. Start new VM and launch Syrius
  6. Go to Settings > Addresses

To trouble shoot this I will build Syrius for windows in debug mode and recreate steps above.

Can confirm this solved the problem

1 Like

This might be fixed in my branch: fixed address label error · zenon-network/syrius@a67ec74 · GitHub

Feel free to compile from source or run one of the releases.

1 Like

I’m going to try this next. Does this release address the .json export issue also?

Not yet, I’m not sourcing the SDK files from my repo. I’m hoping aliencoder accepts the change.

1 Like

I’ve discussed with @sol_sanctum and maybe we can find a more elegant solution. I need to reproduce the issue myself first.

This should help with reproducing the issue.

Have a functioning wallet running
Without closing it entrer your password 3 times so the wallet resets
Create a new wallet and then the bug appears

3 Likes

yes, this OR, clone a VM with syrius setup and running on windows. Open the new VM and the grey box apears.

1 Like

Sorry but I wasn’t able to reproduce the bug the way you’re describing it here.

@sol_sanctum might be able to help as he managed to reproduce it with the same instructions

The problem is this line:

_labelController.text = kAddressLabelMap[widget.address]!;

As it is assumed that kAddressLabelMap[widget.address] is always not null.

I’ll propose a fix, but I want to reproduce the error in order to first test it.

I reproduced it once and haven’t been able to ever since. :frowning_face: