Bridging - High BNB Gas Fees when using the wZNN bridge

Some users run into an issue when attempting to utilize the wZNN <> ZNN Bridge where the transaction lists it is expected to fail with also a high gas fee listed.

The fix is generally simple:

  • Ensure you use 2 decimal places when inputting the amount of wZNN to transfer (instead of hitting the max button for example)

When you try again after this it should come up with a more reasonable BNB gas fee and be successful. If you are still having issues feel free to ask here or in the Telegram.

This Youtube video also explains the issue and solution:

2 Likes

Fix starts at 0:30! If it does not work, try revoking the permissions and refresh the website. After that you can edit the permissions as told in the video.

Good luck!

The ‘quick fix’ I’ve been successfully using for months is to input any wZNN amount (you could even do max), and then input your wallet address. The green button will read ‘Swap’. You must wait a few seconds (around 10 or so) until it reads ‘Enable’. Then, and only then, you will be able to give permissions for the inputed amount with no issues.

If the enable button does not show up, click around, change the wZNN amount or refresh the page. It’s a UI bug where you click swap first instead of enable which is the wrong order of operations. First you must give permissions to use your wZNN and then you can do the swap.

Seems like some sort of UI bug.

I’ve noticed that to quickly force the web app to show the ‘enable’ button instead of the swap one, just clicking back into the wZNN amount field does the trick.

1 Like